The solution to Issuance Date Error when Migrating Date from TCMS V2 to TCMS V3 and Ingress

Tuesday, August 27, 2019 FingerTec 0 Comments



Introduction
Recently, there are several issues related to database migration from TCMS V2 to TCMS V3 and Ingress software. First, user details migrated without the issuance date, wrong issuance date, or expiry date auto-configured to 1/1/2000.



Solutions
Make sure the backup database made with the latest version of TCMS V2 software. Please be informed that the final version of TCMS V2 software is version 2.2.027 with patch date 24-05-2017.

1. If you are using an old version of TCMS V2 software, please update the TCMS Vv2 software to version 2.2.027 by downloading the software installer at the following link.
https://www.fingertec.com/softwareupdate/software-tcmsv2_download_e.html

2. Also, if you are already using TCMS V2 version 2.2.027, please check the patch date version you are using. Go to System Settings > What’s new in this release? And check the patch date.


3. If the software patch date is older than 24-05-2017, please follow the steps below to update the software patch date.

1) Download the latest ft.exe file from this link: https://s3.amazonaws.com/files.fingertec.com/Faiz+Tools/TCMSv2+Software+FT+Setup/ft-75+22027+240517.exe

2) Rename the downloaded file to "ft.exe" (remove all the numbers in the file name, and leave it as ft.exe)

3) Copy the above file, and paste it in TCMS v2 folder (Local Disk C > Program Files (x86) >Fingertec Worldwide > TCMSv2) to replace the existing ft.exe file

4) Relaunch TCMSv2 software - Run as administrator [go to System Settings > What's new in the release > Make sure the version is updated: v2.2.027 24-05-2017

Secondly, please make sure you have installed the latest version of TCMS V3 and Ingress Software before proceeding with the migration process. You are also required to install minimum Microsoft .Net Framework 4.6.2 in your workstation PC. You may refer to the following link for Microsoft .Net Framework 4.6.2 installer.
https://dotnet.microsoft.com/download/dotnet-framework

Lastly, you also required to install Microsoft OLE DB Provider for Visual FoxPro 9.0 in your workstation. The TCMS V2 is using FoxPro database type so, this installer allows the OLE DB in the workstation to give access for Visual FoxPro database and tables for migration purpose. You may download the installer from the following link.
https://www.microsoft.com/en-my/download/details.aspx?id=14839

Note: If some of the screenshots or steps viewed here are different from the ones in the current system, this is due to our continuous effort to improve our system from time to time. Please notify us at info@timeteccloud.com, we update it as soon as possible.

0 comments:

Have any questions or inquiries about FingerTec? Drop your input here.